*

Author Topic: Nice Bump Mapping  (Read 11399 times)

Offline Kaiaatzl

  • An unusual choice for ship's cat
  • Platinum
  • ****
  • Posts: 1918
  • beware of ounce
Re: Nice Bump Mapping
« Reply #15 on: May 26, 2010, 01:43:46 PM »
Sorry for bumping (pun intended), but I wanted to say:  Anyone who has a bug with the fusion or MD (on a mouse) where the weapon will fire when you're holding the button down (to charge the fusion or zoom the MD), try turning Direct3D graphics and bump-mapping on.  It fixed it for me (it still happens with the fusion, but rarely, and now that I can charge fusion, it's much easier to get kills).

I like the bump mapping on robots.  It makes them look more evil (especially Gyro and Gunslinger).

Offline SaladBadger

  • Gold
  • ***
  • Posts: 602
Re: Nice Bump Mapping
« Reply #16 on: May 26, 2010, 01:48:21 PM »
The actual solution to that bug is to cap your framerate below 80 or so, as that's what causes the bug (and single-sided vauss firing on the pyros). VSync might work for that, if your refresh rate is lower than 80.

Offline Foil

  • Gold
  • ***
  • Posts: 642
  • "I've never seen its equal."
Re: Nice Bump Mapping
« Reply #17 on: May 26, 2010, 02:04:31 PM »
He's correct.

The proper fix for not being able to zoom/charge is to ensure your mouse poll-rate (usually around 100Hz) is faster than your framerate.  The best way to do this is with the -framecap x command-line option.


Offline Kaiaatzl

  • An unusual choice for ship's cat
  • Platinum
  • ****
  • Posts: 1918
  • beware of ounce
Re: Nice Bump Mapping
« Reply #18 on: May 26, 2010, 02:56:35 PM »
Strange, because I've always had my framecap at 60, and it didn't seem to help.

Offline Matthew

  • Platinum
  • ****
  • Posts: 1275
    • Globalgamers.de
Re: Nice Bump Mapping
« Reply #19 on: May 26, 2010, 03:28:10 PM »
Do you have a fairly old mouse, perhaps wireless? Maybe it has a really low poll rate for some reason.

 

An Error Has Occurred!

Cannot create references to/from string offsets