*

Author Topic: D3 Mission Briefings not displaying  (Read 1369 times)

Offline TechPro

  • Lt. Commander
  • Platinum
  • ****
  • Posts: 1086
  • Where was I?
D3 Mission Briefings not displaying
« on: July 27, 2015, 08:21:16 AM »
This is kind of a technical issue... Not sure what the problem I, but I suspect a file corruption however I'm not sure what file to replace.

Descent 3 is working just fine, however the mission briefings are not displaying, instead I see the desktop in the same resolution as Descent 3.  Sound is working (I hear the "typing" noises and other briefing sounds) and when I press the escape key the briefings end and moves on the the cut scenes and game play as normal.

Regular Descent 3 mission set and also Mercenary... Initially, everything (briefings and all) were working fine for months, then something unknown happened and the end of mission summary, cut scenes, and briefings stopped displaying even though Descent 3 was continuing as normal.  Video resolution in Descent 3 was set to 640x480 (so?  I like that resolution!) and I tried bumping that up to 800x600.  Once I switched to 800x600 and restarted Descent 3, the video cut scenes worked again and the end of mission summaries also work... but the briefings still do not display (but are obviously running, just not displaying).

Any ideas?

EDIT:  While I was typing this, it occured I hadn't done a very basic troubleshooting step.  I switched from OpenGL to Direct3D and ... everything works ... except not everything draws correctly and gameplay is not as smooth.  Switch back to OpenGL and the problem resumes (but gameplay is good and smooth).   Looks like it's OpenGL related, but I'm not sure what I can do about it.  Video drivers are latest version.  Perhaps a setting needs changed but I don't know what settings to play around with.
« Last Edit: July 27, 2015, 08:42:07 AM by TechPro »

Offline Kaiaatzl

  • An interesting choice for ship's cat
  • Platinum
  • ****
  • Posts: 1862
  • beware of ounce
Re: D3 Mission Briefings not displaying
« Reply #1 on: July 27, 2015, 07:15:30 PM »
You could try downloading nGlide which works just about as well as opengl with Descent 3.

Offline TechPro

  • Lt. Commander
  • Platinum
  • ****
  • Posts: 1086
  • Where was I?
Re: D3 Mission Briefings not displaying
« Reply #2 on: July 29, 2015, 12:54:18 PM »
Hmmm... Haven't tried that before, might be fun!  ;-)

UPDATE: Found (well, corrected) the problem.  Apparently my anti-virus had gotten a bad update/download and was misbehaving.  I discovered other programs that were not behaving correctly and though I'd been running this anti-virus for a month or more it was the most recently added software (other than OS updates).  Uninstalled the anti-virus (Avast!) and everything is now working perfectly.

I also downloaded the nGlide wrapper and tried that out.  Works pretty good though the graphics are grainier than OpenGL or Direct3D.  I think I'll keep it around.

For anyone who's interested ... the system specs are:
  • Compaq Presario CQ50 (laptop)
  • AMD Athlon Dual-Core QL-62 2.00 GHz
  • Installed RAM: 2.00 GB (1.75 GB usable) - I plan on upgrading.
  • Windows 10 Pro, 64-bit - was originally running Vista.  Win10 runs waaaayyyyy better.

I have a 2nd system (a desktop) running Windows 10 and it also has the Avast! anti-virus (one of the few anti-virus programs that was ready to run on Windows 10 at the time).   That system is running perfectly, so it's clear the problem was isolated to the one computer.

This laptop I might rebuild later on with Windows 10 32-bit instead of the 64-bit it currently runs.  32-bit seems to be smoother/faster than 64-bit on the systems with limited amount of RAM.

 

Please Help Support PD!

Recent

Members
Stats
  • Total Posts: 19692
  • Total Topics: 1433
  • Online Today: 26
  • Online Ever: 104
  • (September 02, 2016, 05:27:46 AM)
Users Online
Users: 0
Guests: 14
Total: 14